Skip to main content
Solved

Troubleshooting Facebook Location Pages in Sprout

  • 27 July 2022
  • 4 replies
  • 56 views

Badge

Hi Community! 

I need some help with Facebook location pages. I have a client who has 17 active location pages and one primary parent page. Currently, we schedule content to the primary page via Sprout and FB automatically shares to all of the location pages. 

We’re interested in adding all of the location pages to Sprout for additional analytics + review management. I added one as a trial and ran into a snag. All of our location pages have the same parent name and a descriptor. ie, Company Name (Atlanta). 

When I connected the location page and added it to the Sprout group, both the parent and location pages appear with the same name in both Publishing and Reporting. The descriptors do not appear in Sprout, so there’s no visual way to differentiate them. I’m worried this will cause confusion in scheduling posts to the correct pages and reporting.

So, if you manage Sprout groups with multiple location pages, have you had this issue? Any workarounds, tips, advice?

icon

Best answer by jackie.dunham 28 July 2022, 16:54

View original

4 replies

Userlevel 3
Badge +1

Hi Anna! If you navigate into your Sprout Settings and look under the Account Settings section, you’ll see the option to toggle your Facebook Page Name Display from Page Name to Usernames. We recommend switching to Usernames for multi location use cases as that will help differentiate the pages in Publishing and Reporting. 

Try that out and let me know if that helps!

Jackie

Badge

Hi Jackie, thanks for your response! I’m in Settings > Account Settings, but I don’t see the toggle option you mentioned. Do I need a specific level of access for this feature?

Userlevel 3
Badge +1

Ah yes, account-wide settings are only accessible to the Account Owner and any Manager-level users in your Sprout account. 

Badge

Hi @jackie.dunham, that fixed the issue! The Account Owner changed the setting and we’re all good now. Thank you!!

Reply